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Abstract 

In many scenarios, Windows XP Professional is the ideal environment for developing Microsoft 
Content Management Server 2002 (MCMS) solutions. However when it comes to supporting 
multiple MCMS sites, for example if you are an ISV or consultant developing sites for different 
clients, MCMS on Windows XP has some limitations This article presents an approach to multi-
site MCMS development on Windows XP Professional which avoids these limitations and 
provides an easy way to switch between MCMS ‘instances’. 
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Introduction 

In many scenarios, Windows XP Professional is the ideal environment for developing Microsoft 
Content Management Server 2002 (MCMS) solutions. Windows XP supports all elements of 
MCMS required for development, namely Internet Information Services, SQL Server 2000 
Developer Edition, the Content Server itself, and perhaps most importantly Visual Studio .NET. 
When working in teams, it is also possible to utilise a separate server hosting a shared SQL Server 
2000 database. 
 
However when it comes to supporting multiple MCMS sites, for example if you are an ISV or 
consultant developing sites for different clients, MCMS on Windows XP has some limitations. In 
particular IIS 5.1 on Windows XP does not support multiple Virtual Web Sites. This is important if 
you are developing for clients who may also require or have existing non MCMS content or 
applications hosted under IIS. In these scenarios the MCMS Map Channel Names to Host Header 
Names is often unsuitable, especially if you wish to deploy the MCMS database and application 
to a distinct server once development is complete. Also there is often the security requirement 
for physical separation of client data during development. 
 
This article presents an approach to multi-site MCMS development on Windows XP Professional 
which avoids these limitations and provides an easy way to switch between MCMS ‘instances’. 
 

Note: the approach detailed should also work on Windows 2000 Professional, but has not 
been tested. 

 
Note: neither multiple sites under IIS5.1 or MCMS applications configured under anything 
other than the Default Web Site (Instance 1) are officially supported by Microsoft. The IIS 
Admin utility is also provided as is, without support. Whilst the approach detailed has been 
extensively tested and used to develop many MCMS solutions, it should be followed at your 
own risk! 

 
This article assumes you are familiar with MCMS installation and configuration, and have 
previously developed MCMS applications with Visual Studio .NET. 
 
For more technical articles, news and code samples please visit www.mcmsfaq.com or subscribe 
to the RSS feed at www.mcmsfaq.com/rss.asp to keep up to date with new content related to 
Content Management Server. If you would like to send feedback on this article, please email the 
author.  
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MindXpand IIS Admin 

The IIS Admin utility from MindXpand allows for the creation of multiple Virtual Web Sites under 
Windows XP Professional and provides a GUI to quickly switch between them. Once IIS Admin 
has been used to create multiple sites, Internet Services Manager can also be used in the normal 
manner to set configuration properties, such as logging and security. IIS Admin is more suitable 
than other ISAPI based solutions or Cassini-Ex, because it will support all MCMS and ASP.NET 
related IIS configuration. To install, extract the ZIP file and run the iisadmin.msi file. The 
following screen shot shows the IIS Admin user interface: 

 
Note: IIS Admin does not remove the limitation in Windows XP which prevents more than 
one Virtual Web Site being started concurrently.  

 

Pre-requisites 

Before proceeding, ensure that Content Management Server 2002 Service Pack 1a is installed 
and configured by following the product installation guide and the default installation locations. 
In the examples presented, the MCMS System Account is LOCAL_MACHINE\mcmssys and the 
Initial MCMS Administrator Account is the account under which you are currently logged on. 
You can substitute these accounts if required. To follow the steps in this article the logged on 
user also needs to be a local administrator. In addition, the WoodgroveNet and OTGWeb MCMS 
sample sites should be installed and functioning correctly before continuing. This article assumes 
you are using Visual Studio .NET 2003. For the purposes of this article we will configure two 
distinct MCMS applications, both of which are hosted under their own IIS Virtual Web Site and 
utilise their own SQL Server 2000 database. We won’t touch the Default Web Site. The 
configuration is shown below: 
 

Name: Webroot Directory: Database: Description: 

Woodgrove C:\Inetpub\woodgrove MCMSWoodgrove WoodgroveNet Sample Site 

OTGWeb C:\Inetpub\otgweb MCMSOTGWeb OTGWeb Sample Site 
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Creating and Configuring Databases 

We will start by creating the two MCMS databases and configuring the appropriate access for 
the MCMS System Account. 
 

1. From the Start Menu, click Programs, followed by Microsoft SQL Server, followed by 
Enterprise Manager. 

2. Expand the Microsoft SQL Servers and SQL Server Group nodes, and expand your 
server (which by default is named (local)). 

3. Right click Databases and click New Database… 
4. On the Database Properties dialog, enter MCMSWoodgrove in the Name text box and 

click OK. 
5. Right click Databases and click New Database… 
6. On the Database Properties dialog, enter MCMSOTGWeb in the Name text box and click 

OK. 
7. Expand the Security node, and click the Logins node. 
8. In the Logins pane, double click the MACHINE_NAME\mcmssys Login. 
9. On the SQL Server Login Properties dialog, click the Database Access tab. 
10. Select the Permit check box to the left of the MCMSOTGWeb database. 
11. In the Database roles for ‘MCMSOTGWeb’ view, select the db_ddladmin, 

db_datareader and db_datawriter roles: 

 
12. Select the Permit check box to the left of the MCMSWoodgrove database. 
13. In the Database roles for ‘MCMSWoodgrove’ view, select the db_ddladmin, 

db_datareader and db_datawriter roles. 
14. Click OK to close the SQL Server Login Properties dialog, and close Enterprise 

Manager. 
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Creating and Configuring Virtual Web Sites 

Next we will set up the file system, use IIS Admin to create two new Virtual Web Sites, configure 
FrontPage Server Extensions, and copy the required ASP.NET and Internet Explorer Web Controls 
client components. 
 

1. Use Windows Explorer to create the folders C:\Inetpub\woodgrove and 
C:\Inetpub\otgweb. 

2. From the Start Menu, click Programs, followed by IIS Admin, followed by IIS Admin. 
3. Right click the IIS Admin icon in the system tray, and click Open IIS Admin: 

4. On the IIS Admin window, click New Site. 
5. On the dialog, enter Woodgrove in the Website Name text box, and select the 

c:\Inetpub\woodgrove folder in the Directory tree view and click OK: 

6. On the IIS Admin window, click New Site. 
7. On the dialog, enter OTGWeb in the Website Name text box, and select the 

c:\Inetpub\otgweb folder in the Directory tree view and click OK. 
8. On the IIS Admin window, select the Woodgrove site, and click Start., followed by 

Hide. 
9. From the Start Menu, click Programs, followed by Administrative Tools, followed by 

Internet Information Services. 
10. Expand the MACHINE_NAME node, followed by the Web Sites folder. 
11. Right click the Woodgrove Virtual Web Site, followed by All Tasks, followed by 

Configure Server Extensions: 
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12. On the Welcome to the Server Extensions Configuration Wizard page, click Next. 
13. On the Create Windows Groups page, deselect the Create local machine Groups 

check box and click Next: 

14. On the Access Control page, click Next: 

15. On the Mail Server page, select the No. I’ll do it later. radio button and click Next: 

16. On the Completing the Server Extensions Configuration Wizard page, click Finish. 
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17. Right click the IIS Admin icon in the system tray and click OTGWeb: 

18. Switch back to the Internet Information Services Administration Console, click the 
Web Sites folder and click the Refresh toolbar button. 

19. Right click the OTGWeb Virtual Web Site, followed by All Tasks, followed by Configure 
Server Extensions. 

20. On the Welcome to the Server Extensions Configuration Wizard page, click Next. 
21. On the Create Windows Groups page, deselect the Create local machine Groups 

check box and click Next. 
22. On the Access Control page, click Next. 
23. On the Mail Server page, select the No. I’ll do it later. radio button and click Next. 
24. On the Completing the Server Extensions Configuration Wizard page, click Finish. 
25. Use Windows Explorer to navigate to the C:\Inetpub\wwwroot\ folder.  
26. Select the aspnet_client and webctrl_client folders, and choose Copy from the 

Edit menu. 
27. Navigate to the C:\Inetpub\woodgrove folder and choose Paste from the Edit 

menu. 
28. Navigate to the C:\Inetpub\otgweb folder and choose Paste from the Edit menu. 
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Installing the Schema and Configuring Entry Points 

In this section we will install the MCMS database schema into the two previously created 
databases, setup the initial MCMS Administrator to be the currently logged on user and 
configure the MCMS Entry Points. 
 

1. From the Start Menu, click Programs, followed by Microsoft Content Management 
Server, followed by Database Configuration Application, and click Next. 

2. On the Stop Services message box, click Yes. 
3. On the Select MCMS Database page, click Select Database. 
4. On the SQL Server Login dialog enter a period (.) in the Server select box, and click 

Options >>. 
5. Select MCMSOTGWeb in the Database select box, and click OK: 

6. Click Next, and on the Empty database dialog, click Yes. 
7. On the Database Population page, click Next. 
8. On the Select Initial MCMS Administrator page enter your credentials (the user 

username and password of the currently logged on user), and click Next: 

9. Once the DCA has completed, clear the Launch the SCA Now check box, and click 
Finish. 

10. From the Start Menu, click Programs, followed by Microsoft Content Management 
Server, followed by Database Configuration Application, and click Next. 
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11. On the Stop Services message box, click Yes. 
12. On the Select MCMS Database page, click Select Database. 
13. On the SQL Server Login dialog enter a period (.) in the Server select box, and click 

Options >>. 
14. Select MCMSWoodgrove in the Database select box, and click OK, followed by Next. 
15. On the Empty database dialog, click Yes. 
16. On the Database Population page, click Next. 
17. On the Select Initial MCMS Administrator page enter your credentials (the user 

username and password of the currently logged on user), and click Next: 
18. Once the DCA has completed, clear the Launch the SCA Now check box, and click 

Finish. 
 

Note: The MCMS Server Configuration Application is installed on the Default Web Site as 
part of the default MCMS installation on Windows XP. As the Default Web Site is stopped, it 
will fail to load if the Launch the SCA Now check box is selected in the steps above. 

 
19. Right click the IIS Admin icon in the system tray and click Default Web Site. 
20. From the Start Menu, click Programs, followed by Microsoft Content Management 

Server, followed by Server Configuration Application. 
21. Click the Web tab, followed by Configure… 
22. Set the MCMS? property of Woodgrove and OTGWeb to Yes - Read Write. When 

prompted about adding or removing entry points, click OK: 
 
 
 
 
 
 
 
 
 
 

 
23. Click OK, and close the Server Configuration Application. 

 
 
At this stage we now have two ‘empty’ Web sites and databases which you can use for 
MCMS development. If you wish to see the technique demonstrated using sample sites, 
continue with the next section, Configuring the MCMS Sample Sites. 
 
If you wish to use this approach to develop MCMS sites from scratch using Visual 
Studio .NET, skip the next section, and go directly to the Developing MCMS Sites from 
scratch using Visual Studio .NET section. 
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Configuring the MCMS Sample Sites 

At this stage we now have two ‘empty’ Web sites and databases which you can use for MCMS 
development. To demonstrate this we will now configure one of the previously installed MCMS 
sample sites on each ‘instance’ of MCMS by importing sample data, configuring IIS Virtual 
Directories and using the DCA and IIS Admin to switch between them. 
 

1. Right click the IIS Admin icon in the system tray, and ensure the Woodgrove Virtual 
Web Site is selected. 

2. From the Start Menu, click Programs, followed by Microsoft Content Management 
Server, followed by Site Manager. 

3. On the Server Information dialog, click OK. 
4. On the Logon dialog, click Start. 
5. From the Site Manager File menu, choose Package, followed by Import… 
6. On the Site Deployment Import window click Browse… 
7. Navigate to the C:\Program Files\Microsoft Content Management 

Server\Sample Data\WoodgroveNet folder, select the WoodgroveNet.sdo file 
and click Open. 

8. In the Container Rules tab, select the Use package container rights radio button, and 
the Replace with package container rights radio button: 

9. Click the Rights Groups tab, and select the Import User Rights Groups radio button: 

10. Click Import, and on the Import Confirmation dialog, click Continue. 
11. Once the import has completed, click OK on the informational dialog. 
12. Close the Site Deployment Import window. 
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13. Using Site Manager you can browse the hierarchy to view the imported assets: 

14. Close Site Manager. 
15. From the Start Menu, click Programs, followed by Administrative Tools, followed by 

Internet Information Services. 
16. Expand the MACHINE_NAME node, followed by the Web Sites folder. 
17. Right click the Woodgrove Virtual Web Site, followed by New, followed by Virtual 

Directory… 
18. On the Welcome to the Virtual Directory Creation Wizard page, click Next. 
19. On the Virtual Directory Alias page, enter WoodgroveNet in the Alias text box, and 

click Next: 

20. On the Web Site Content Directory page, enter C:\Program Files\Microsoft 
Content Management Server\Sample Data\WoodgroveNet in the Directory 
text box (or use the Browse… button to locate the folder) and click Next: 
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21. On the Access Permissions page, click Next: 

22. On the You have successfully completed the Virtual Directory Creation Wizard 
page, click Finish. 

23. Right click the WoodgroveNet Virtual Directory, followed by New, followed by Virtual 
Directory… 

24. On the Welcome to the Virtual Directory Creation Wizard page, click Next. 
25. On the Virtual Directory Alias page, enter cms in the Alias text box, and click Next. 
26. On the Web Site Content Directory page, enter C:\Program Files\Microsoft 

Content Management Server\Server\IIS_CMS in the Directory text box (or use 
the Browse… button to locate the folder) and click Next. 

27. On the Access Permissions page, click Next. 
28. On the You have successfully completed the Virtual Directory Creation Wizard 

page, click Finish. 
29. Right click the cms Virtual Directory, and click Properties. 
30. On the cms Properties dialog, on the Virtual Directory tab, click Remove, followed by 

OK:  



© 2004, Optimum Media Ltd.  www.mcmsfaq.com Page 13 of 20
 

31. Note that the icon displayed in Internet Information Services for the cms Virtual 
Directory has changed to reflect it is no longer an application: 

32. Expand the MCMS Virtual Directory, right click the McmsHomeport virtual directory, 
and click Properties 

33. On the McmsHomeport Properties dialog, on the Virtual Directory tab, click Create, 
followed by OK. 

34. Close Internet Information Services. 
35. At this stage, you can test the WoodgroveNet sample by opening Internet Explorer and 

browsing to  http://localhost/channels, clicking the WoodgoveNet link, 
logging on, switching to edit mode etc: 

36. You can also test Visual Studio.NET development by opening C:\Program 
Files\Microsoft Content Management Server\Sample 

Data\WoodgroveNet\WoodgroveNet.sln. 
 

Note:  When opening the WoodgroveNet solution you will be prompted to upgrade it to be 
compatible with Visual Studio .NET 2003. 

 
37. Close Internet Explorer and Visual Studio.NET. 
38. From the Start Menu, click Programs, followed by Microsoft Content Management 

Server, followed by Database Configuration Application, and click Next. 
39. On the Stop Services message box, click Yes. 
40. On the Select MCMS Database page, click Select Database. 
41. On the SQL Server Login dialog enter a period (.) in the Server select box, and click 

Options >>. 
42. Select MCMSOTGWeb in the Database select box, and click OK: 
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43. Click Next, and on the Use Existing Database dialog, click Yes: 

44. On the Add an Administrator dialog, click No: 

45. Once the DCA has completed, clear the Launch the SCA Now check box, and click 
Finish. 

46. From the Start Menu, click Programs, followed by Microsoft Content Management 
Server, followed by Site Manager. 

47. On the Server Information dialog, click OK. 
48. On the Logon dialog, click Start. 
49. From the Site Manager File menu, choose Package, followed by Import… 
50. On the Site Deployment Import window click Browse… 
51. Navigate to the C:\Program Files\Microsoft WSS 

Books\eBusiness\Enterprise Intranet Sites folder, select the OTGWeb.sdo 
file and click Open. 

52. Click Import, and on the Import Confirmation dialog, click Continue. 
 

Note:  There is no need to configure Rights Groups as the OTGWeb sample does not include 
any Rights Groups or Users. 

 
53. Once the import has completed, click OK on the informational dialog. 
54. Close the Site Deployment Import window. 
55. Using Site Manager you can browse the hierarchy to view the imported assets. 
56. Close Site Manager. 
57. Right click the IIS Admin icon click the OTGWeb Virtual Web Site. 
58. From the Start Menu, click Programs, followed by Administrative Tools, followed by 

Internet Information Services. 
59. Expand the MACHINE_NAME node, followed by the Web Sites folder. 
60. Right click the OTGWeb Virtual Web Site, followed by New, followed by Virtual 

Directory… 
61. On the Welcome to the Virtual Directory Creation Wizard page, click Next. 
62. On the Virtual Directory Alias page, enter OTGWeb in the Alias text box, and click Next. 
63. On the Web Site Content Directory page, enter C:\Program Files\Microsoft 

WSS Books\eBusiness\Enterprise Intranet Sites in the Directory text box 
(or use the Browse… button to locate the folder) and click Next. 

64. On the Access Permissions page, click Next. 
65. On the You have successfully completed the Virtual Directory Creation Wizard 

page, click Finish. 
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66. Right click the OTGWeb Virtual Directory, followed by New, followed by Virtual 
Directory… 

67. On the Welcome to the Virtual Directory Creation Wizard page, click Next. 
68. On the Virtual Directory Alias page, enter cms in the Alias text box, and click Next. 
69. On the Web Site Content Directory page, enter C:\Program Files\Microsoft 

Content Management Server\Server\IIS_CMS in the Directory text box (or use 
the Browse… button to locate the folder) and click Next. 

70. On the Access Permissions page, click Next. 
71. On the You have successfully completed the Virtual Directory Creation Wizard 

page, click Finish. 
72. Right click the cms Virtual Directory, and click Properties. 
73. On the cms Properties dialog, on the Virtual Directory tab, click Remove, followed by 

OK. 
74. Close Internet Information Services. 
75. At this stage, you can test the OTGWeb sample by opening Internet Explorer and 

browsing to  http://localhost/OTGWeb, switching to edit mode etc: 

76. You can also test Visual Studio.NET development by opening C:\Program 
Files\Microsoft WSS Books\eBusiness\Enterprise Intranet Sites 
OTGWeb.sln. 

 
Note:  You may wish to copy the WoodgroveNet and OTGWeb sample folders to another 
location to keep them separate from those used by the Default Web Site. If so simply 
substitute the file paths in the above steps. 

 
 
The next section details developing MCMS sites from scratch using Visual Studio .NET, if 
you wish you can skip this next section, and go directly to the Switching between 
‘Instances’  section. 
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Developing MCMS Sites from scratch using Visual Studio .NET 

At this stage we now have two ‘empty’ Web sites and databases which you can use for MCMS 
development. Developing sites from ‘scratch’, using Visual Studio .NET rather than installing the 
sample sites, requires a number of additional steps to enable Visual Studio .NET to access your 
Virtual Web Sites and set up the correct Virtual Directories during the New Project creation. 
 

Note:  This section makes use of the databases and Virtual Web Sites created earlier, you 
may wish to rename these to reflect the MCMS applications you are developing. 

 
Note:  Due to MCMS only supporting the Default Web Site, we will modify Virtual Web Site 
Ports, create our MCMS applications, and then reset the Ports and edit the files created by 
Visual Studio .NET. You could however continue to develop against Virtual Web Sites with 
different ports, in which case skip steps 31 through 64. 

 
1. Right click the IIS Admin icon in the system tray, and ensure the Woodgrove Virtual 

Web Site is selected. 
2. From the Start Menu, click Programs, followed by Administrative Tools, followed by 

Internet Information Services. 
3. Expand the MACHINE_NAME node, followed by the Web Sites folder. 
4. Right click the Woodgrove Virtual Web Site, and click Properties. 
5. On the Web Site tab, in the Web Site Identification pane, enter 81 in the TCP Port 

text box, and click OK. 
6. If prompted to Restart IIS, click Yes, and wait until IIS is restarted. 
7. Right click the OTGWeb Virtual Web Site, and click Properties. 
8. On the Web Site tab, in the Web Site Identification pane, enter 82 in the TCP Port 

text box, and click OK. 
9. If prompted to Restart IIS, click Yes, and wait until IIS is restarted. 
10. If necessary, right click the Woodgrove Virtual Web Site, and click Start. 
11. Close Internet Information Services. 
12. Using Windows Explorer, navigate to the C:\Program Files\Microsoft Content 

Management Server\DevTools folder. 
13. Open the DeveloperTools.xml file using Notepad (or your editor of choice). 
14. Within the CmsEnvironment element, set the Server InstanceID attribute to 2: 

<CmsEnvironment> 

<Server BaseUrl="http://localhost" InstanceId="2"/> 

<Template QueryString=""/> 

</CmsEnvironment> 

 

Note:  It is not necessary to add a port to this URL. 

 
15. From the File menu, click Save. 
16. Open Visual Studio .NET, and from the File menu, choose New, followed by Project…  
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17. In the Project Types box, expand the Content Management Server Projects folder, 
and click the Visual C# Projects folder. 

18. In the Templates box, click MCMS Web Application. 
19. In the Location text box, enter http://localhost:81/MCMSMSD1, and click OK, 

wait until the MCMS application is created. 
20. From the File menu, choose Save All… and close Visual Studio .NET. 
 

Note:  If you examine the MCMSMSD1 application using Internet Information Services, the 
cms Virtual Directory will not appear. However Visual Studio .NET has created it, and it does 
exist! This can be verified by attempting to create another Virtual Directory with the same 
alias (doing so is impossible). This can also be verified by examining the MCMSMSD1/CMS 
node using MetaEdit 2.2. 

 
21. Right click the IIS Admin icon in the system tray and click the OTGWeb Virtual Web Site. 
22. Switch back to Notepad (or the editor which has DeveloperTools.xml open). 
23. Within the CmsEnvironment element, set the Server InstanceID attribute to 3: 

<CmsEnvironment> 

<Server BaseUrl="http://localhost" InstanceId="3"/> 

<Template QueryString=""/> 

</CmsEnvironment> 
24. From the File menu, click Save. 
25. Close Notepad (or the editor which has DeveloperTools.xml open). 
26. Open Visual Studio .NET, and from the File menu, choose New, followed by Project…  
27. In the Project Types box, expand the Content Management Server Projects folder, 

and click the Visual C# Projects folder. 
28. In the Templates box, click MCMS Web Application. 
29. In the Location text box, enter http://localhost:82/MCMSMSD2, and click OK, 

wait until the MCMS application is created. 
30. From the File menu, choose Save All… and close Visual Studio .NET. 

 
Note: If you wish to continue to develop against Virtual Web Sites with different ports you 
can skip the remaining steps in this section. 

 
31. From the Start Menu, click Programs, followed by Administrative Tools, followed by 

Internet Information Services. 
32. Expand the MACHINE_NAME node, followed by the Web Sites folder. 
33. Right click the Woodgrove Virtual Web Site, and click Properties. 
34. On the Web Site tab, in the Web Site Identification pane, enter 80 in the TCP Port 

text box, and click OK. 
35. If prompted to Restart IIS, click Yes, and wait until IIS is restarted. 
36. Right click the OTGWeb Virtual Web Site, and click Properties. 
37. On the Web Site tab, in the Web Site Identification pane, enter 80 in the TCP Port 

text box, and click OK. 
38. If prompted to Restart IIS, click Yes, and wait until IIS is restarted. 
39. If necessary, right click the Woodgrove Virtual Web Site, and click Start. 
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40. Close Internet Information Services. 
41. Using Windows Explorer, navigate to the C:\Documents and 

Settings\USER_NAME\My Documents\Visual Studio Projects\MCMSMSD1 
folder (where USER_NAME is the username of the currently logged on user). 

42. Select the two files, and click the Edit menu, followed by Cut. 
43. Navigate to the C:\Inetpub\woodgrove\MCMSMSD1 folder and click the Edit menu, 

followed by Paste. 
44. Using Windows Explorer, navigate to the C:\Documents and 

Settings\USER_NAME\My Documents\Visual Studio Projects\MCMSMSD2 

folder (where USER_NAME is the username of the currently logged on user). 
45. Select the two files, and click the Edit menu, followed by Cut. 
46. Navigate to the C:\Inetpub\otgweb\MCMSMSD2 folder and click the Edit menu, 

followed by Paste. 
47. Using Windows Explorer, navigate to the C:\Inetpub\woodgrove\MCMSMSD1 folder. 
48. Open the MCMSMSD1.sln file using Notepad. 
49. On the second line, remove the port within the URL (i.e. change 

http://localhost:81/MCMSMSD1/MCMSMSD1.csproj to 
http://localhost/MCMSMSD1/MCMSMSD1.csproj). 

50. From the File menu, click Save. 
51. Open the MCMSMSD1.csproj.webinfo file using Notepad. 
52. Remove the port from the URLPath attribute of the Web element (i.e. <Web URLPath 

= "http://localhost/MCMSMSD1/MCMSMSD1.csproj" />). 
53. From the File menu, click Save. 
54. Using Windows Explorer, navigate to the C:\Inetpub\otgweb\MCMSMSD2 folder. 
55. Open the MCMSMSD2.sln file using Notepad. 
56. On the second line, remove the port within the URL. 
57. From the File menu, click Save. 
58. Open the MCMSMSD2.csproj.webinfo file using Notepad. 
59. Remove the port from the URLPath attribute of the Web element. 
60. From the File menu, click Save. 
61. Close Notepad. 
62. Test the MCMSMSD1 application by opening 

C:\Inetpub\woodgrove\MCMSMSD1\MCMSMSD1.sln in Visual Studio .NET 
63. Right click the IIS Admin icon in the system tray, and click the OTGWeb Virtual Web 

Site. 
64. Test the MCMSDEV2 application by opening 

C:\Inetpub\otgweb\MCMSMSD2\MCMSMSD2.sln in Visual Studio .NET. 
 

 
Note:  It is important to remember that DeveloperTools.xml is in the same state as when we 
completed step 23. If we wish to create more ‘instances’ or develop against the Default Web 
Site we must remember to modify this file again. 
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Switching between ‘Instances’ 

Now the two ‘instances’ are setup, you can switch between them easily by running the Database 
Configuration Application to select the correct database, and IIS Admin to select the correct 
Virtual Web Site. 
 

1. From the Start Menu, click Programs, followed by Microsoft Content Management 
Server, followed by Database Configuration Application, and click Next. 

2. On the Stop Services message box, click Yes. 
3. On the Select MCMS Database page, click Select Database. 
4. On the SQL Server Login dialog enter a period (.) in the Server select box, and click 

Options >>. 
5. Select the desired MCMS database in the Database select box, and click OK: 
6. Click Next, and on the Use Existing Database dialog, click Yes: 

7. On the Add an Administrator dialog, click No: 

8. Once the DCA has completed, clear the Launch the SCA Now check box, and click 
Finish. 

9. Right click the IIS Admin icon in the system tray and click the desired Virtual Web Site. 
10. Open the C:\Program Files\Microsoft Content Management 

Server\DevTools\DeveloperTools.xml file using Notepad (or your editor of 
choice). 

11. Within the CmsEnvironment element, set the Server InstanceID to match the 
instance ID for the desired Virtual Web Site (which is displayed in the IIS Admin window): 

12. From the File menu, click Save, and close Notepad. 
 

Note:  Steps 10-12 are only required if you wish to use the Template Gallery Item browse 
facility in Visual Studio.NET. You can manually enter paths for the TemplateFile property 
without editing DeveloperTools.xml. 
Once you edit DeveloperTools.xml you must restart Visual Studio .NET for the changes to 
take effect. 

 
13. Open the applications in Internet Explorer or Visual Studio .NET to develop and test your 

MCMS applications as normal. 



© 2004, Optimum Media Ltd.  www.mcmsfaq.com Page 20 of 20
 

Links to Further Information 

 
• MCMS News, Technical Articles, Code Samples, FAQs, KBs, White Papers 

http://www.mcmsfaq.com 
http://www.mcmsfaq.com/rss.asp 

 
• Stefan Goßner’s Blog 

http://blogs.msdn.com/stefan_gossner 

 
• MCMS Installation Guide 

http://www.microsoft.com/cmserver/cms_installing.htm 

 
• MCMS FAQ 

http://download.microsoft.com/download/4/2/5/4250f79a-c3a1-4003-9272-2404e92bb76a/MCMS+2002+-

+(complete)+FAQ.htm 

 

• Accessing a MCMS Web site different from the Default Web site 

http://download.microsoft.com/download/4/2/5/4250f79a-c3a1-4003-9272-2404e92bb76a/MCMS+2002+-

+(complete)+FAQ.htm#AF0A8BBF-1488-450F-ADD1-E555312ADEC9 

 

 

Downloads Related to this Article 

 
• WoodgroveNet Sample Site 

http://download.microsoft.com/download/a/a/1/aa121cac-2a05-4602-8416-233e7b6779ca/WoodgroveNet.zip 

 
• OTGWeb Sample Site 

http://download.microsoft.com/download/1/e/4/1e49e06c-73bb-497b-b4c0-

1f7075467cf0/Enterprise%20Intranet%20Sites.msi 

 
• IIS Admin 

http://www.mindxpand.be/iisadmin/iisadmin.zip 

 
• MetaEdit 2.2 

http://download.microsoft.com/download/iis50/Utility/5.0/NT45/EN-US/MtaEdt22.exe 
 


